Sun Microsystems, Inc.
spacerspacer
spacer   www.sun.com docs.sun.com | | |  
spacer
black dot
   
A   B   C   D   E   F   G   H   I   J   K   L   M   N   O   P   Q   R   S   T   U   V   W   X   Y   Z
    
 
Kernel Functions for Driverspci_config_setup(9F)


NAME

 pci_config_setup, pci_config_teardown - setup or tear down the resources for enabling accesses to the PCI Local Bus Configuration space

SYNOPSIS

 
#include <sys/ddi.h>
 #include <sys/sunddi.h> 
int pci_config_setup(dev_info_t *dip, ddi_acc_handle_t *handle);
 void pci_config_teardown(ddi_acc_handle_t *handle);

INTERFACE LEVEL

 

Solaris DDI specific (Solaris DDI).

PARAMETERS

 
dip
Pointer to the device's dev_info structure.
handle
Pointer to a data access handle.

DESCRIPTION

 

pci_config_setup() sets up the necessary resources for enabling subsequent data accesses to the PCI Local Bus Configuration space. pci_config_teardown() reclaims and removes those resources represented by the data access handle returned from pci_config_setup().

RETURN VALUES

 

pci_config_setup() returns:

DDI_SUCCESS
Successfully setup the resources.
DDI_FAILURE
Unable to allocate resources for setup.

CONTEXT

 

pci_config_setup() must be called from user or kernel context. pci_config_teardown() can be called from any context.

NOTES

 

These functions are specific to PCI bus device drivers. For drivers using these functions, a single source to support devices with multiple bus versions may not be easy to maintain.

ATTRIBUTES

 

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPEATTRIBUTE VALUE
ArchitecturePCI Local Bus

SEE ALSO

 

attributes(5)

IEEE 1275 PCI Bus Binding


SunOS 5.9Go To TopLast Changed 1 Jan 1997

 
      
      
Copyright 2002 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms.