|System Administration Commands||kdmconfig(1M)
| ||kdmconfig - configure or unconfigure keyboard, display, and mouse options for OpenWindows and internationalization
| ||kdmconfig [-fv] [-s hostname] -c | -t | -u | -d filename
The kdmconfig program configures or unconfigures the /etc/openwin/server/etc/OWconfig file with the keyboard, display, and mouse information relevant to a client's
machine on IA based systems for Solaris software. kdmconfig can also be used to set up the display, pointer, and keyboard entries in the bootparams(4) database
on a server machine or the monitor, keyboard, display, and pointer keywords in a sysidcfg(4) file. kdmconfig can only be run by the super-user. Upon completion
of device selection, kdmconfig prompts the user to test the configuration, which is done by running the window system.
The kdmconfig program is normally run during installation and upon reboot, but it can also be run from the command line after the system has been installed. When configuring a client
during an initial installation or a reconfigure reboot, the sysidconfig(1M) program
will invoke kdmconfig with the -c option, and when the user executes the sys-unconfig(1M) program, kdmconfig will be executed with
the -u option. Similarly, when you run kdmconfig from the command line, use the -u option to unconfigure the existing OpenWindows configuration. You can
then rerun kdmconfig with the -cf options to create a new OpenWindows configuration. To edit the existing configuration, run kdmconfig from the command
line without options. After each reboot, kdmconfig will be invoked by the system with the -t (test mode) option to ensure autoconfiguration capability and identify possible
conflicts between the current configuration and the one recorded in the OWconfig file.
The valid options are:
- Run the program in the configuration mode. This mode is used to create or update the OWconfig file. When invoked in this way, kdmconfig first looks for the relevant configuration information in the bootparams(4) databases. It also takes into account the information returned from device probes, unless the -s
option is also used. The bootparams(4) databases available
to the client are all of the /etc/bootparams files on servers on the same subnet as the client, provided the server machine is running the bootparamd(1M) daemon. kdmconfig is invoked with the -c option when called by sysidconfig(1M)
- -d filename
- Set up a sysidcfg(4) file. This option displays the same screens as the -c option, but the information you specify is saved as sysidcfg(4) keywords (monitor, keyboard, display, and pointer). This enables you to use a sysidcfg (4)
file to preconfigure a system's device information and bypass kdmconfig during an installation.
filename is the sysidcfg(4)
file that is created, and it is created in the directory where kdmconfig is being run unless a path is specified. If filename already exists in the specified directory, the keywords are
appended to the existing file.
- Force screens mode. When this option is invoked, no network probing will be performed. This is helpful when debugging the client's configuration
environment. Note that the -s option implies the use of -f, bypassing network probing when setting up a server.
- -s hostname
- Set up the bootparams(4) database on this machine for the specified client. This option presents the same screens as it does when run on a client, but instead writes
the resulting information to the /etc/bootparams file. Also, -s implies the use of the -f option. That is, the program will always present the screens
to the user when invoked this way. This option will reconfigure the nsswitch.conf( 4) file to look for a bootparams(4) database
on a local server. This option is only available to the super-user.
- Run the program in test mode. In this mode, kdmconfig will use device probe information to determine whether the OWconfig file contains complete and up-to-date information about the keyboard, display, and mouse. If the information is accurate, kdmconfig will exit silently. Otherwise, kdmconfig will prompt for the super-user password and proceed to a normal editing session (as though it had been run without options).
- Unconfigure the system, returning it to an "out-of-the-box" state. In this state, the factory default keyboard, mouse, and display are selected
as a result of removing the device configuration entries from the /etc/openwin/server/etc/OWconfig file. This may result in an unusable configuration for the display server.
- Enable verbose mode. Normally, kdmconfig will not produce any output. This option is helpful for debugging, as it records
the different actions taken by kdmconfig on stderr.
Run without options, kdmconfig is used to edit the current configuration. kdmconfig uses the information from the OWconfig file in addition
to information obtained from the bootparams(4) file and from
device probes. In other respects, it is similar to using the -c option of kdmconfig.
- OpenWindows configuration file
- contains list of clients that diskless clients use for booting
- name service configuration file
- installed devices and properties
See attributes(5) for descriptions of the following
|ATTRIBUTE TYPE||ATTRIBUTE VALUE