|System Administration Commands||in.rdisc(1M)
| ||in.rdisc, rdisc - network router discovery daemon
| ||/usr/sbin/in.rdisc [-a] [-f] [-s] [send-address] [receive-address]
| ||/usr/sbin/in.rdisc -r [-p preference] [-T interval] [send-address] [receive-address]
implements the ICMP router discovery protocol. The first form of the command is used on hosts and the second form is used on routers.
At boot time, in.rdisc is invoked in either the first form (host mode) or second form (router mode). The second form is invoked under the following conditions:
- A machine has multiple interfaces
- The interfaces are not configured by DHCP
- The defaultrouter(4) and /etc/notrouter files are not present
Otherwise, the first form of in.rdisc is invoked.
On a host, in.rdisc populates the network routing tables with default routes. On a router, advertises the router to all the hosts.
Host (First Form)
On a host, in.rdisc listens on the ALL_HOSTS (184.108.40.206) multicast address for ROUTER_ADVERTISE messages from routers. The received messages are handled by first ignoring those listed router addresses
with which the host does not share a network. Among the remaining addresses, the ones with the highest preference are selected as default routers and a default route is entered in the kernel routing table for each one of them.
Optionally, in.rdisc can avoid waiting for routers to announce themselves by sending out a few ROUTER_SOLICITATION messages to the ALL_ROUTERS (220.127.116.11) multicast address when it is started.
A timer is associated with each router address. The address will no longer be considered for inclusion in the routing tables if the timer expires before a new advertise message is received from the router. The address will also be excluded from consideration if the host
receives an advertise message with the preference being maximally negative or with a lifetime of zero.
Router (Second Form)
When in.rdisc is started on a router, it uses the SIOCGIFCONF ioctl(2) to find the interfaces configured
into the system and it starts listening on the ALL_ROUTERS multicast address on all the interfaces that support multicast. It sends out advertise messages to the ALL_HOSTS multicast address advertising
all its IP addresses. A few initial advertise messages are sent out during the first 30 seconds and after that it will transmit advertise messages approximately every 600 seconds.
When in.rdisc receives a solicitation message, it sends an advertise message to the host that sent the solicitation message.
When in.rdisc is terminated by a signal, it sends out an advertise message with the preference being maximally negative.
- Accept all routers independent of the preference they have in their advertise messages. Normally, in.rdisc only accepts (and enters in the kernel routing
tables) the router or routers with the highest preference.
- Run in.rdisc forever even if no routers are found. Normally, in.rdisc gives up if it has not received any advertise message after soliciting three times, in which case it exits
with a non-zero exit code. If -f is not specified in the first form then -s must be specified.
- Act as a router, rather than a host.
- Send three solicitation messages initially to quickly discover the routers when the system is booted. When -s is specified, in.rdisc exits with a non-zero exit code if it can not
find any routers. This can be overridden with the -f option.
- -p preference
- Set the preference transmitted in the solicitation messages. The default is zero.
- -T interval
- Set the interval between transmitting the advertise messages. The default time is 600 seconds.
- A file that acts as a flag for a boot-time script that determines whether a machine will act as a router or a host. The presence of the notrouter file prevents a machine that does not have a default route from
acting as an IPv4 router, even if that machine has multiple interfaces.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE
in.routed(1M), ioctl(2), defaultrouter(4), attributes(5), icmp(7P), inet(7P)
Deering, S.E., editor, ICMP Router Discovery Messages, RFC 1256, Network Information Center, SRI International, Menlo Park, California, September 1991.