|System Administration Commands||dhcpmgr(1M)
| ||dhcpmgr - graphical interface for managing DHCP service
dhcpmgr is a graphical user interface which enables you to manage the Dynamic Host Configuration Protocol (DHCP) service on the local system. It performs the functions of the dhcpconfig, dhtadm, and pntadm
command line utilities. You must be root to use dhcpmgr. The dhcpmgr Help, available from the Help menu, contains detailed information about using the tool.
You can perform the following tasks using dhcpmgr:
- Configure DHCP service
- Use dhcpmgr to configure the DHCP daemon as a DHCP server, and select the data store to use for storing network configuration tables..
- Configure BOOTP relay service
- Use dhcpmgr to configure the DHCP daemon as a BOOTP relay.
- Manage DHCP or BOOTP relay service
- Use dhcpmgr to start, stop, enable, disable or unconfigure the DHCP service or BOOTP relay service, or change DHCP server parameters.
- Manage DHCP addresses
- Use dhcpmgr to add, modify, or delete IP addresses leased by the DHCP service.
- Manage DHCP macros
- Use dhcpmgr to add, modify or delete macros used to supply configuration parameters to DHCP clients.
- Manage DHCP options
- Use dhcpmgr to add, modify or delete options used to define parameters deliverable through DHCP.
- Convert to a new DHCP data store
- Use dhcpmgr to configure the DHCP server to use a different data store, and convert the DHCP data to the format used by the new data store.
- Move DHCP data to another server
- Use dhcpmgr to export data from one Solaris DHCP server and import data onto another Solaris DHCP server.
The following exit values are returned:
- Successful completion.
- An error occurred.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE