true does nothing, successfully. false does nothing, unsuccessfully. They are typically used in a shell script sh as:
which executes command forever.
true has exit status 0.
false always will exit with a non-zero value.
See attributes(5) for descriptions of the following