how use an edited version of cat5rancid

Andrew Partan asp at
Thu Oct 16 19:41:05 UTC 2003

On Thu, Oct 16, 2003 at 10:36:51AM -0700, Jason Truong wrote:
> So I am using "cat5" for mfg for my cisco catalyst switches.
> However, when I run do-diffs, nothing happens for the cat3548s.
> When I run rancid or cat5rancid (for debugging) I get errors.
> Basically, some of the called commands from the scripts don't work

I never remember which ciscos are best done with type 'cisco'
(rancid) or type 'cat5' (cat5rancid).  I usually use rancid 1st,
and if that fails, then use cat5rancid.  [See bin/rancid-fe for the
bit that goes from type to program.]

In any case, the 'missed cmds' message means that the program
(cat5rancid in this case) has problems logging into the router &
could not run all of the commands.  The programs deal with 'command
not found' or 'invalid command' just fine; its when they can't even
run the commands that they complain about missed commands.

So I'd look into why you can't log into the router & run commands.
Can you use clogin to log into the routers having problems?  Can
you run some commands with:
	clogin -c "show version;show version" rtr1
without problems?

Btw, the missed commands that you listed are *all* of the commands
that cat5rancid is trying to run - i.e.: it was unable to run any
of them.

More information about the Rancid-discuss mailing list