[rancid] f5rancid.in how to ? (TMSH on BigIP)

Alan McKinnon alan.mckinnon at gmail.com
Sat Jan 11 23:37:02 UTC 2014

On 10/01/2014 19:05, tom gilmore wrote:
> I have been trying to get f5rancid to collect configs from our BigIP
> boxes. They are running BigIP version 11.0
> I have download several f5rancid.in patches,, but none of them seem to work.
> the most common error that I see is "command' not found when I attempt
> to run ./f5rancidin -d x.x.x.x
> I can see the @commandtable has the correct list of commands that can
> collect information from me ,, but I cannot get the script to work.
> for example,, I downloaded this patch found under gossemer threads
> http://www.gossamer-threads.com/lists/engine?do=post_attachment;postatt_id=255;list=rancid
> but when I run the script,, I get these errors
> (essentially the first 50 lines of f5rancid.in are commented out,, so
> "command not found" is seen on line 51
> ******************************
>  ./f5rancid -d
> : command not found 
> : command not found 
> ./f5rancid: line 51: use: command not found
> : command not found: 
> ./f5rancid: line 52: syntax error near unexpected token `'dflV''
> '/f5rancid: line 52: `getopts('dflV');
> *******************************
> Line 51 says "use Getopt::Std;"
> Line 52 -55 says 
> getopts('dflV');
> if ($opt_V) {
>     print "@PACKAGE@ @VERSION@\n";
>     exit(0);
> }

install GetOpt::Std

It's a perl module and it's missing on your system.

This is a package manager problem and is solved there; it is not caused
by rancid. All the subsequent syntax errors are caused by that module
being missing, so the perl interpreter has no idea what to do

Alan McKinnon
alan.mckinnon at gmail.com

More information about the Rancid-discuss mailing list