[rancid] Rancid sending "diff -U 4" mails instead of actual diffs

john heasley heas at shrubbery.net
Tue Jul 26 16:40:43 UTC 2011

Tue, Jul 26, 2011 at 03:51:22PM +0300, Mircea Ionita:
> > I've been having a problem with rancid lately, that is, it is sending
> > mails containing "diff -U -4 -r1.437 <dev name>" instead of actual
> > diffs. I ran into this problem after I solved the initial issue, which
> > was that rancid was sending empty emails (solved, more or less, by
> > using the solution found on the group, which was to change the diff
> > option from "-u" to "-U"). Now the mails don't come as often (and as
> > empty) as before, but every time i make a change on a device, the
> > abovementioned is the only thing I get. I must add that in CVS the
> > diffs appear properly, as they should.

the cvs diff just pipes to sendmail, with To (etc) headers written to
sendmail's stdin.  so, test that yourself to make sure that it works.
see the control_rancid script.

More information about the Rancid-discuss mailing list