[rancid] Re: RCSSYS=svn error: svn: Directory <group> is out of date (incl. patch)

john heasley heas at shrubbery.net
Thu Aug 5 18:43:16 UTC 2010

Wed, Aug 04, 2010 at 07:13:59PM +0200, "Peter Valdemar M?rch (Lists)":
> When I try to use the svn RCSSYS I get this error in the log file on the 
> rancid in debian stable, rancid-core 2.3.2~a8-4, when running rancid-run 
> for the first time:
> > All routers sucessfully completed.
> >
> > Sending        .
> > svn: Commit failed (details follow):
> > svn: Directory '/cmhosts' is out of date
> Similar questions were posted here:
> http://www.shrubbery.net/pipermail/rancid-discuss/2007-February/002037.html
> http://www.shrubbery.net/pipermail/rancid-discuss/2006-June/001568.html
> http://www.shrubbery.net/pipermail/rancid-discuss/2009-October/thread.html#4306
> http://www.shrubbery.net/pipermail/rancid-discuss/2010-February/004621.html
> with no answers, except:
> > Someone or something must be mucking with your respository.  I'd suggest
> > that you change the ownership & permissions of the files and directories
> > where your repository lies such that no other can alter them.
> No, that is not the case... Nobody else is mucking with it, I promise.
> Running with CVS and there are no problems. I've looked in the changelog 
> for 2.3.3 and 2.3.4 and subversion/svn is not mentioned.
> Does svn work for anybody else?
> Is there a bug here?
> Has this been fixed in 2.3.4? Would it help to upgrade to 2.3.4 (I'd 
> rather keep all my /usr controlled with debian packages unless I have to 
> manually install...)
> I've tried to install the patch in 
> http://www.shrubbery.net/pipermail/rancid-discuss/2006-August/001679.html (which 

it should not be necessary to svn/cvs update prior to running rancid
for a group.  if the checkout in rancid's dir needs an update, then
someone other than rancid commited a change - or your machine crashed and
munged the fsys or your version of cvs/svn has a problem or someone killed
a cvs/svn process that rancid was running.  so, either someone is trying to
hide config changes or something is broken.

ie: we'd rather know that there is intereference or a problem than have
rancid run the update.  this has NEVER occured on my rancid boxes; I'm
using cvs primarily and have used svn for testing only.

the second part of that patch should also not be necessary; a) localhost
is not necessary, but the url should be file:///$CVSROOT/$GROUP, and b)
the update should not necessary unless something is broken.  I'd apply
either or both of these if I understood why either would be necessary.

> isn't applied to 2.3.4 either) but it doesn't completely fix the issue. 
> Is there any reason why this patch wasn't applied or even commented on? 
> The only reference I could find to it was in 
> http://www.shrubbery.net/pipermail/rancid-discuss/2007-February/002046.html 
> that says that it worked if I ran rancid-run twice. Which is true, it does.
> This patch *does* fix it though. I'm just worried why nobody else is 
> seeing this:
> --- orig.control_rancid.in	2010-08-04 19:09:03.000000000 +0200
> +++ control_rancid.in	2010-08-04 19:09:43.000000000 +0200
> @@ -299,6 +299,13 @@
>       cd $DIR
>   fi
> +
> +# svn update to avoid 'Out of date' error
> +if [ "$RCSSYS" = "svn" ]
> +then
> +    svn update
> +fi
> +
>   mv -f routers.all.new routers.all
>   if [ $? -ne 0 ] ; then
>       echo "Error: could not rename routers.all.new"
> Peter
> -- 
> Peter Valdemar M?rch
> http://www.morch.com
> _______________________________________________
> Rancid-discuss mailing list
> Rancid-discuss at shrubbery.net
> http://www.shrubbery.net/mailman/listinfo.cgi/rancid-discuss

More information about the Rancid-discuss mailing list