[rancid] Re: ASA flapping diffs with "names" or "no names"

john heasley heas at shrubbery.net
Wed Nov 25 19:13:39 UTC 2009

Wed, Nov 25, 2009 at 10:06:27AM +0000, Shane Kavanagh:
> All
> I am seeing similar which happed in the early hours of the morning, I am not
> seeing the reverse,
> If I connect to the device and do a show run I see "no names" in the running
> config but not in the start-up config.  The show run also tells me that my
> config has not been changed since 18th November, therefore I must conclude
> that this addition in the config did not get added by the CLI or Web
> interface but by other means.  I am starting to look at bug tracker on
> cisco.com for SNMP bugs.
> Do a "show version" from the enabled CLI
> this will tell you the last user to modify the config and the date and time
> when this was done
> "Configuration last modified by <XXX> at 10:38:56.343 UTC Wed Nov 18 2009"
> Check this with the time and date of the rancid config, I get rancid to pull
> configs every hour and I could pin point this to a one hour window between 6
> and 7 am
> check your stat up config
> "show startup-config | include no names"
> Its not in my start up config.
> However on other ASA's I am see this and it flips several times a day
>   !BootFlash: Current BOOT variable = disk0:/asa804-k8.bin
>   !BootFlash: CONFIG_FILE variable =
>   !BootFlash: Current CONFIG_FILE variable =
>   !
> - !BootFlash: BOOT variable = disk0:/asa804-k8.bin
> + !BootFlash: BOOT variable =

this is either an IOS bug or a problem with the nvram; more likely the

More information about the Rancid-discuss mailing list