[rancid] Re: rancid don't create configurations files

Chris Bell CBell at thig.com
Fri Dec 19 14:00:22 UTC 2008

I believe he fixed this by re-installing rancid under the "rancid" user.
It was apparently a permissions issue. 

-----Original Message-----
From: rancid-discuss-bounces at shrubbery.net
[mailto:rancid-discuss-bounces at shrubbery.net] On Behalf Of Joachim
Jerberg Jensen
Sent: Thursday, December 18, 2008 10:24 AM
To: Arne Larsen / Region Nordjylland; 'rancid-discuss at shrubbery.net'
Subject: [rancid] Re: rancid don't create configurations files

>On Wednesday, December 10, 2008 9:03 PM, Arne Larsen wrote:
>Hi all

Hi Arne,

>Can someone help me out.

Have you solved your problem yet?

>i've install rancid on a Centos5, and configured it as I belive it
should, but I don't get any configurations into the file structure.
>If I run .cloginrc -c " sh run " and pipe it into a file I get the
configuration of the router.
>If I run rancid-run, and at the same time do a tcpdump then I can see
the connect to the router from rancid and  also a lot off packets being
transferred from the router to rancid.
>But I never get a list of configurations files.
>I don't get a log file in /var/log either.

Rancid should generate a logfile in like /usr/local/var/rancid/logs
depending on where you have installed rancid.
In these logs, you should see some kind of an error. The logfile is
named "thegroup.date.time"


Joachim Jerberg Jensen

>What can I be missing here. I run rancid-run as rancid user.
>Here is the extensions of the created file.: -rw-r----- 1 rancid rancid
0 Dec 10 20:49 testsw1
Rancid-discuss mailing list
Rancid-discuss at shrubbery.net

More information about the Rancid-discuss mailing list