[rancid] fnrancid and Fortinet equipment

Eric Humphries ehumphri at gmail.com
Sun Sep 17 20:49:17 UTC 2006

Hey guys,

I'm using rancid on a FreeBSD 6.1-Stable box, and I'm trying to log into
some fortinet equipment (more specifically a Fortigate 60M) using the
fnrancid module.

I'm able to manually use clogin to log into the firewall and it brings me to
the prompt but immediately after the session freezes and I'm unable to
type/run commands. Using rancid-run fails to run the commands as well so it
appears to be something with how the script expects the login prompt to
appear, possibly. The hostname I have on the device is "testdevice $" when I
log in as a user and "testdevice #" when I log in with admin. There is not
enable password required.

I'm quite new to rancid (a few days) and I've searched around for help
regarding this specific issue but I've yet to find anything that matches my
problem well. I can provide information as necessary, just tell me what you
need to see.

Is there something I'm doing wrong that would cause the shell to hang? I've
tried running rancid with tcsh, and sh - both with the same result.

Thanks in advance for your suggestions.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20060917/b9fb6f72/attachment.html 

More information about the Rancid-discuss mailing list