[rancid] Re: clogin interactive works, non-interactive doesn't

Michael W. Lucas mwlucas at blackhelicopters.org
Thu Jun 8 19:55:49 UTC 2006

On Thu, Jun 08, 2006 at 12:17:55PM -0400, Michael W. Lucas wrote:
> Hi,
> I'm using rancid 2.3.1 on FreeBSD 6.1, built from ports, and am having
> a problem with run-rancid.  Rancid runs as the user "rancid" with a
> homedir of /home/rancid, much like many other people on this list.
> When I run clogin from the command line, I can issue commands to all
> the routers to my heart's content.  When I run rancid-run, however, my
> log fills up with:
> host.name clogin error: Error: TIMEOUT reached
> (plus lists of the commands that failed, of course)
> Any suggestions on where to look?
> Thanks,
> ==ml

Followup to my own post so the answer gets in the archives:

rancid-run works fine with plain hostnames in router.db, but choked on
FQDN.  While FQDN would be nice, it isn't vital for me.

Thanks for all the private mail of suggestions!

==ml (who, once again, should have gone to lunch *before* sending an
email saying he had a problem...)

Michael W. Lucas	mwlucas at FreeBSD.org, mwlucas at BlackHelicopters.org
	    Latest book: PGP & GPG -- http://www.pgpandgpg.com
"The cloak of anonymity protects me from the nuisance of caring." -Non Sequitur

More information about the Rancid-discuss mailing list