how use an edited version of cat5rancid

Mark Duling mark.duling at
Thu Oct 16 21:43:37 UTC 2003

>I have successfully installed rancid and it working great for some 
>of my Cisco switches.
>The ones that work are for the Cisco Catalyst 4003.
>I have a bunch of Catalyst 3548s that don't appear to work.
>In my router.db file I have:
>So I am using "cat5" for mfg for my cisco catalyst switches. 
>However, when I run do-diffs, nothing happens for the cat3548s. When 
>I run rancid or cat5rancid (for debugging) I get errors.  Basically, 
>some of the called commands from the scripts don't work .. ie

Catalyst 3548's run IOS so you need to use the 'cisco' RANCID 
directive.  On the other hand, Catalyst 2980's (which are Catalyst 
4000 series switches) run CatOS.  So just because the model is a 
Catalyst doesn't mean it is running CatOS.  I don't know why the 
Cisco naming is so convoluted.  If a 'show ver' on the switch reveals 
that the binary OS image starts with 'cat' such as cat4000.6-3-3a.bin 
then it's running CatOS and you need to use the RANCID directive 
'cat5'.  Otherwise it is running IOS and needs to use RANCID 
directive 'cisco'.

There may be exceptions to this.  That is the way it looks to me 
based on the Cisco equipment I happen to have.


More information about the Rancid-discuss mailing list