[rancid] rancid 2.3.6: clogin with multiple devices fails... ($autologin not defined)

Jon Peatfield J.S.Peatfield at damtp.cam.ac.uk
Wed Jul 6 14:55:44 UTC 2011

On Thu, 23 Jun 2011, Lee wrote:

> Hi,
>> <deathly quiet>
>> So is this something specific to my copy of rancid, or is this just a well
>> known thing to be avoided?
> I'd never tried it before, so I stayed quiet :)   But it's easy enough
> to test, so
>  clogin -c "sh ip eigrp int"  router1 router2 router3 ... router20
> worked for me using rancid 2.3.6

As discussed off the list, it works ok if clogin isn't set to use enable 
ie if you have autoenable or noenable set.

The bug seems is triggered if the $enable variable gets set, then the next 
time round the loop it calls code which references a variable which isn't 
defined (anywhere in the code).

I can see a number of possible fixes to the current clogin code but would 
prefer an expert to take a look at it...

  -- Jon

More information about the Rancid-discuss mailing list