[rancid] Making zrancid work from cron

Tore Anderson tore.anderson at redpill-linpro.com
Fri Jul 30 12:45:24 UTC 2010

Hi list,

I've got problems making RANCID fetch the config from a Quagga box when
running from cron.  It works fine when running from the command line,
but from cron I just get a "TIMEOUT reached" error in my logs.  It seems
the problem is with the pseudo-terminal allocation.  To demonstrate:  if
I add «clogin -t 10 -c"show version;write term" rtr» to the rancid
user's crontab, the mail I get in return contains:

> rtr
> spawn ssh -c 3des -x -l rancid rtr
> Linux rtr 2.6.32-22-server x86_64
> Ubuntu 10.04.1 LTS
> This node is configured by puppet. Local changes may be overwritten.
> Last login: Fri Jul 30 14:22:02 2010 from 2001:db8:1002:102:214:22ff:fe12:99d9
> Hello, this is Quagga (version 0.99.16).
> Copyright 1996-2005 Kunihiro Ishiguro, et al.
> WARNING: terminal is not fully functional
> -  (press RETURN)
> Error: TIMEOUT reached

I tried adding «-tt» to the ssh command line in clogin, but that had no
effect.  It works very well when I run it from the command line myself,
though.  Any suggestions on how to solve this would be greatly appreciated!

Best regards,
Tore Anderson
Redpill Linpro AS - http://www.redpill-linpro.com/
Tel: +47 21 54 41 27

More information about the Rancid-discuss mailing list