[rancid] Still not working RANCID (2.3.4) with Cisco w/o 'enable'

Aleksey P paleola at gmail.com
Thu Aug 5 09:24:02 UTC 2010

Good day, some weeks ago i have a problem that Racnid didn't work  if i only
have unprivelege mode on Cisco device (only > promt).
In 2.3.4 version there is changes that i want - "rancid: Accept '>' prompt,
rather than just '#'"

I am clear all my old Rancid file and configs and install 2.3.4 version, but
it still the same:
At the end of /usr/local/libexec/rancid/rancid file i commented all
commands, and insert instead "show running-config" - "show configuration"

OS - FreeBSD
Here some of config:
/usr/local/libexec/rancid]# vi /usr/local/etc/rancid/.cloginrc
add noenable 1
#add autoenable 1
add user username
add password password
add method ssh*

All work just fine - no enable promt - show configuration- that is all we
 /usr/local/libexec/rancid/clogin -t 90 -c"show configuration"
spawn ssh -c 3des -x -l username
username at's password:*
and here we can see all information from  'show **configuration**' command*

If i try run rancid-run in my logs i will see:
*Getting missed routers: round 2. missed cmd(s): show **configuration*
* End of run not found
and so on.

If i make all of that with enable configuration (# promt) - all works fine.

Help me pls!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20100805/7d7ff7e9/attachment.html 

More information about the Rancid-discuss mailing list