[rancid] Problem with CVS repository

Désiré dmosuna at gmail.com
Thu Apr 30 11:51:16 UTC 2009

Hi, i've got a problem with CVS repository.

In fact, I've got all my groups in /opt/rancid/var:
rancid at debian:~/var$ ls
Chatillon  CVS  cvsroot  DataCenter  Dr  Etab  logs  Marseille

Then for example in Marseille, i've got :
rancid at debian:~/var/Marseille$ ls
configs  CVS  router.db  routers.all  routers.down  routers.up

In configs, I've got all the configs of my equipements.It's ok.

Then, if i go in /opt/rancid/var/CVS :
rancid at debian:~/var/CVS$ ls
Chatillon  CVSROOT  Datacenter  Dr  Entries.Log  Etab  Marseille

Then, in Marseille, i've got
rancid at debian:~/var/CVS/Marseille$ ls
configs  router.db,v

In configs, I'got a directory called Attic and all the directories are in

But, when i access by web interface, and if i want to see the config of my
it is written :
Error: Marseille/configs/Attic/**** is not (any longer) pertinent

And when i go to see in the logs when i've run it for the first time,it is
/opt/rancid/var/CVS/Marseille/configs/****,v  <--  *****
new revision: delete; previous revision:
Deleted ******

and afterwards when re-running, it's written :
cvs status: use `cvs add' to create an entry for `****'
cvs add: Re-adding file `****' after dead revision 1.2.
cvs add: use `cvs commit' to add this file permanently
cvs added missing router ****

cvs remove: removed `****'
Deleted ****

Can you guide me please to see where the problem come from.
I've recently upgrade the version  to 2.3.2a9.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20090430/02cfa01d/attachment.html 

More information about the Rancid-discuss mailing list