[rancid] problem getting postfix to send to aliases

anon anon gnuisancev3 at gmail.com
Mon Sep 22 19:20:07 UTC 2008

I currently have rancid installed but it seems for the life of me I'm never
going to get this system to send mails outside of this box.  It's a Debian
box, attempted exim at first and gave up on that and moved to postfix.  I'm
not 100% certain that even if I get postfix to do it's thing if rancid will
use it correctly at this point.  Unfortunately, I haven't been the only one
on this project and many people have stuck their fingers in it without
documenting what changes they have made.

The problem I have those is I'll change the /etc/aliases file and do a

In the /etc/postfix/main.cf I have the following:  (mind you i'm editting
out our domain name).

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = richxnet01.domain.com, localhost.domain.com, localhost
mynetworks =
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
relayhost = <our ip for our smtp server >

my /etc/alias file looks like this:

# /etc/aliases
mailer-daemon: postmaster
postmaster: root
nobody: root
hostmaster: root
usenet: root
news: root
webmaster: root
www: root
ftp: root
abuse: root
noc: root
security: root
root: postmaster@
rancid-admin-Juniper: my-name at cavtel.com
rancid-admin-Cisco:  my-name at cavtel.com
rancid-Cisco:  my-name at cavtel.com
racid-Test:  my-name@

my /etc/mailname file looks like this: (again, domain editted)


and I will do the following to send a test message:

*#telnet localhost 25*
Connected to localhost.
Escape character is '^]'.
220 localhost ESMTP Postfix (Ubuntu)*
*ehlo mail*
250-SIZE 10240000
*mail from: <test at test.com>*
*250 Ok*
*rcpt to: <rancid-Test>               *(also have tried  rancid-admin-Cisco)
250 Ok
*354 End data with .
* *Subject: This is a test !*
*Wake up please!*
*250 Ok: queued as BD8261C01D4*
*Connection closed by foreign host.*

Doing a tail /var/log/mail.log  gets me the following:

   1. Sep 22 14:39:16 RICHXNET01 postfix/smtpd[4552]: disconnect from
   2. Sep 22 14:45:01 RICHXNET01 postfix/smtpd[5114]: connect from
   3. Sep 22 14:45:15 RICHXNET01 postfix/smtpd[5114]: disconnect from
   4. Sep 22 14:45:22 RICHXNET01 postfix/smtpd[5114]: connect from
   5. Sep 22 14:45:44 RICHXNET01 postfix/smtpd[5114]: 2A3615B4F8:
   6. Sep 22 14:45:54 RICHXNET01 postfix/cleanup[5422]: 2A3615B4F8:
   message-id=<20080922184544.2A3615B4F8 at richxnet01.localdomain>
   7. Sep 22 14:45:54 RICHXNET01 postfix/qmgr[31788]: 2A3615B4F8: from=<
   tst at tst.com>, size=367, nrcpt=1 (queue active)
   8. Sep 22 14:45:55 RICHXNET01 postfix/smtp[5490]: 2A3615B4F8: to=<
   rancid-Test at my-domain.com>, orig_to=<rancid-Test>, relay=[]:25, delay=21, delays=20/0.01/0/0.09, dsn=2.6.0,
   status=sent (250 2.6.0  <20080922184544.2A3615B4F8 at richxnet01.localdomain>
   Queued mail for delivery)
   9. Sep 22 14:45:55 RICHXNET01 postfix/qmgr[31788]: 2A3615B4F8: removed
   10. Sep 22 14:45:56 RICHXNET01 postfix/smtpd[5114]: disconnect from

It seems the name i'm mailing to is simply getting the domain name appended
to it and it's completely ignoring the alias file all together.  Rancid is
all setup, the cron jobs are good to go, but when i run "rancid-run" I do
not recieve any mail.

Excuse any ignorance I'm displaying, I've never played with rancid, postfix,
or exim before at all.  I've tried other avenues for assistance with the
postfix folk, but haven't gotten much help.  Anything anyone could provide
would be greatly appreciated I've been going in circles with this for 2
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20080922/19f13075/attachment.html 

More information about the Rancid-discuss mailing list