[rancid] Re: RANCID against Adtran IAD 900

Peter Serwe peter.serwe at gmail.com
Sat Dec 6 01:22:05 UTC 2008

Oh wow.. I never even knew someone had written an adtran specific rancid script.

I have been looking for this for months, using the standard cisco device type.

John - what are the chances we can get this stuff included in the next alpha?

I have failed every time I tried to integrate one.

Also, I use these Adtran devices extensively, and I have two in a lab
environment I could
provide access to for script development.  One is a Netvanta 6355 and
the other is a Total Access 908e.

Both use AOS and should be completely interoperable for Rancid.  The
lab is booked at the moment doing
interop testing with a class 5 telco switch, but should free up
relatively shortly.


On Fri, Dec 5, 2008 at 3:40 PM, Mike Ashcraft <mashcraft at omniture.com> wrote:
> Larry,
> Check your logs for "unknown router manufacturer"
> You did not indicate that you had added an entry for router type
> adrancid in /usr/local/rancid/bin/rancid-fe
> something like:
> elsif ($vendor =~ /^adrancid$/i) { exec('adrancid', $router); }
> Mike
> Kemp, Larry wrote:
>> Hey guys...
>> We have Rancid running great hourly diff-ing and backing up our
>> configs for all our Cisco gear on our entire network. We are really
>> happy with it and happy being part of this group, the Rancid community
>> here has made all the difference to us. So thanks to all of you!
>> We are now trying to get Rancid to work with my Adtran IAD 900's. The
>> internal operating system essentially functions just like a Cisco
>> router. Mr. Ted Cabeen wrote a great script for use on the Adtran IAD
>> 900's too…located here:
>> http://osdir.com/ml/network.rancid/2006-08/msg00025.html.
>> We think rancid-run is executing the lines from the router.db and
>> .cloginrc files because in the
>> /usr/local/rancid/var/networking/configs directory we see a file with
>> the IP-address of my IAD appear and we get the email telling us it was
>> added. However when we look at the file in
>> /usr/local/rancid/var/networking/configs (named after that devices
>> IP-address) that file is empty. The IP is NOT showing up in the
>> routers.down or the routers.failed files.
>> I took Ted Cabeen's script and named it
>> /usr/local/rancid/bin/adrancid, I placed this file "adrancid" in this
>> directory with all the other executables (/see this file attached/).
>> In the /usr/local/rancid/var/networking/router.db file I have this
>> device listed as:
>> In the /usr/local/rancid/.cloginrc file I have the following commands
>> listed for this device:
>> # Device at IP address
>> add password /the-rancid-account's-password/
>> /our-device's-enable-password/
>> add user rancid
>> add userprompt
>> add method {telnet}
>> I am using:
>> - Cent OS version 5.2
>> - Rancid version 2.3..2a2
>> - Perl version 5.8.8
>> - Expect version 5.43.0-5.1.i386
>> - VI Improved version 7.0.237
>> I have not been able to find any info on correcting this problem
>> online (where maybe somebody else has run into this too). I am
>> thinking that maybe I need to change something simple in the
>> /router.db/, /.cloginrc/ or rancid.conf files. If anyone has
>> successfully gotten these Adtran IAD 900's to work with Rancid, we
>> sure could use some minor guidance on what config you are using or how
>> you solved this if you ran into it too.
>> Thank you!
>> Respectfully,
>> Larry Kemp
>> Bonita Springs FL USA
>> ------------------------------------------------------------------------
>> _______________________________________________
>> Rancid-discuss mailing list
>> Rancid-discuss at shrubbery.net
>> http://www.shrubbery.net/mailman/listinfo.cgi/rancid-discuss
> _______________________________________________
> Rancid-discuss mailing list
> Rancid-discuss at shrubbery.net
> http://www.shrubbery.net/mailman/listinfo.cgi/rancid-discuss


More information about the Rancid-discuss mailing list