[rancid] "command not found" error

William Yardley rancid at veggiechinese.net
Tue Jun 6 20:40:36 UTC 2006

When running /usr/local/rancid/bin/rancid-run, I get:

/usr/local/rancid/bin/rancid-run: line 59: rancid:: command not found

Rancid still works, but the error is very confusing (especially since
Rancid doesn't really send anything to stdout / stderr while it's

I *think* it's talking about line 59 of rancid.conf, not line 59 of
rancid-run - I have (in the config):

# list of rancid groups
# For each group, define a list of people to receive the diffs.
# in sendmail's /etc/aliases.
rancid: user1,user2
MAILDOMAIN="@example.com"; export MAILDOMAIN

This seems correct from a quick look at the example config file.

I do have /usr/local/rancid/run in $PATH in my environment. I tried
suing to the user running rancid (usually I run it as "sudo -u
ranciduser /path/to/rancid/rancid-run), but that didn't change anything.
"which rancid" does return the correct rancid.


More information about the Rancid-discuss mailing list