rancid hangs on 'show controllers'

David C davidc at sargasso.net
Fri Mar 12 07:44:00 UTC 2004

Hello. I have a 1750, just upgraded to 12.3(6). Rancid hangs when 
polling this device. I did a 'ps' to see the clogin line used:

clogin -t 90 -c "show version;show install active;show env all;show gsr 
chassis;show boot;show bootvar;show variables boot;show flash;dir /all 
nvram:;dir /all bootflash:;dir /all slot0:;dir /all disk0:;dir /all 
slot1:;dir /all disk1:;dir /all slot2:;dir /all disk2:;dir /all 
sup-bootflash:;dir /all sup-microcode:;show controllers;show controllers 
cbus;show diagbus;show diag;show module;show c7200;show vtp status;show 
vlan;write term" myrouter.sargasso.net

Running this manually, I see that it hangs on the penultimate line on 
'show controllers':

  PHY registers:
  Register 00 2100
  Register 01 780D
  Register 02 7810
  Register 03 0003
  Register 04 01E1
  Register 05 0000
  Register 06 0001
  Register 16 0000
  Register 17 0000
  Register 18 4000
  Register 19 0800

When I run show controllers from the console, I get a final line for 
Register 20, followed by two blank lines, followed by the prompt:

  Register 20 38C8


Any idea why it is hanging at this point? Removing the 'show 
controllers' from the clogin makes it work (though I don't if it's a 
good idea to edit rancid itself to remove this).

Running manual 'clogin myrouter' and then executing show controllers 
does not hang.

Here are the lines from .cloginrc:

add password myrouter.sargasso.net mypass
add method myrouter.sargasso.net ssh
add user myrouter.sargasso.net david
add userpassword myrouter.sargasso.net mypass
add autoenable myrouter.sargasso.net 1

Like I say, it worked before this IOS upgrade.

Many thanks for any assistance

More information about the Rancid-discuss mailing list