Prompt issues on Bay routers.

Mark Cooper mcooper at
Sat Sep 20 02:55:52 UTC 2003

stefmit wrote:
> For whatever reasons, in all Nortel/Bat routers I have tried this, blogin 
> never makes it this far (as in "reaching the logout"). It gets me to the TI 
> prompt ($), and I can run commands there, but even when typing "logout" (!!!) 
> I cannot actually log out of the router(s). Telnet-ing "normally" (i.e. no 
> "blogin")  into those same routers, and running commands, then a logout, 
> allows me to cleanly close the sessions ... very odd ...

I don't remember blogin being an interactive process?? You should be 
able to do something like blogin -c 'bcc; show config' routername if not 
can you post or email me the output?

> blogin/brancid never make it as far as getting to a bcc prompt (whether be it 
> "bcc>" or - even furfther - "box#"). I was referring to a normal login 
> session, going through TI, then typing bcc. All my Nortel routers hve at 
> least 32MB of RAM, and they handle small frame relay sites, with very small 
> tables, and not very much traffic.

Can you post/email me the router.raw file after doing:-
	setenv NOPIPE=YES
	brancid -d routername

> No, it hasn't - one can do a "show config" under TI, without having to go into 
> bcc. The issue with bcc being the subject of this email thread was started by 
> someone's question about the equivalent of "enable" in the Nortel/Bat world. 
> I have explained as much as I was able to - in my initial response to that 
> query - what is the difference between TI and bcc ... and the thought was to 
> provide enough info to change the blogin/brancid to be able to handle a whole 
> session (login (telnet) into TI -->[router-ID]$bcc --> bcc>config --> 
> box#exit --> bcc>exit -->[router-ID]logout) properly. I do not think that 
> anybody was ever able to use blogin/brancid beyond the login to TI 
> capability.

OK, herein lies the problem. When I originally ported clogin/rancid to 
the Bay Networks kit that we were using at the time, you *HAD* to enter 
bcc to run the show config command. I have no idea what version of BayOS 
they were running at the time...but it was quite some time ago now :) 
Can you confirm what version(s) you are running?
I do remember seeing someone post about problems with blogin/brancid a 
while back, which they solved by changing the "more off" to "config cli 
more false" and "show config -all" to "show config verbose".

If, as you say, you can run the "show config" command in TI mode, than 
brancid can be simplified from:-
         'bcc'                   => "RunCommand",
         'show config'           => "ShowConfig",
         'show config -all'      => "ShowConfig",


         'show config'           => "ShowConfig",

try testing this by doing blogin -c 'show config' routername
Again, if this doesn't work, please post/email me the output - hopefully 
than I can get a better idea what is going wrong :)



Mark Cooper - Network Management with Attitude - Open Source PVR Hardware Database

More information about the Rancid-discuss mailing list